Probleme mit analogen 4-20mA Ausgängen

Diskutiere Probleme mit analogen 4-20mA Ausgängen im Elektronik allgemein Forum im Bereich WEITERE ELEKTROTECHNISCHE BEREICHE; Hallo, ich habe mich gerade an meine Poolsteuerung gemacht und auf eine Raspi3 umgestellt. Um die diversen Messwerte zu visualisieren habe ich...

  1. #1 alterlich, 15.04.2018
    alterlich

    alterlich Lüsterklemmer

    Dabei seit:
    06.09.2009
    Beiträge:
    748
    Zustimmungen:
    5
    Hallo,

    ich habe mich gerade an meine Poolsteuerung gemacht und auf eine Raspi3 umgestellt.
    Um die diversen Messwerte zu visualisieren habe ich eine Widgetlords 8 fach AI Karte angeschlossen.

    Mein erstes auszulesendes Gerät ist ein 230V Gerät und hat zwei analoge Ausgänge. Wenn ich beide an die Eingänge A1 (- an COM) und A2 (- an und COM) der AI Karte anschließe, bekomme ich korrekte Werte in beiden Kanälen.
    Wenn ich jetzt aber das nächste Gerät (hängt an externem 24V DC Netzgerät) mit + und - an Eingang A3 und COM anhänge geht der Strom sofort über den Messbereich. Ich habe dann einmal die Karte abgetrennt und 100 Ohm bürde rein und mit Multimeter gemessen, dann passt es und ich bekomme exakt 4mA (bei 0 Pegel) wie es sein sollte.
    Die COM der Karte sind alle Intern verdrahtet, d.h. ich ziehe mir den - des zweiten Geräts über COM auf das potential des - des ersten Geräts. Das ist offenbar schlecht???

    Wie löst man sowas. Also mehrere 0-20mA Geräte auslesen an einer AI Karte, bei der die COMS allse zusammen geschlatet sind ?
    Was kann ich (ich hab noch mehrere Geräte die wohl das selbe Problem erzeugen werden) tun??

    HIer mal ein Link zur IA Karte
    https://cdn.shopify.com/s/files/1/0258/5531/files/Pi-SPi-8AI-Schematic.pdf?18021431991385118386

    Wäre echt nett, wenn sich ein Spezialist mal der Sache annehmen könnte

    Gruss
     
  2. Anzeige

  3. #2 _Martin_, 16.04.2018
    _Martin_

    _Martin_ Strippenstrolch

    Dabei seit:
    05.08.2017
    Beiträge:
    116
    Zustimmungen:
    10
    Die Analogsignale kann man mit Trennverstärkern galvanisch entkoppeln.
     
  4. gert

    gert Freiluftschalter

    Dabei seit:
    28.09.2007
    Beiträge:
    5.286
    Zustimmungen:
    81
    Die galvanische Trennung mit Trennverstärkern /Speisetrennern kostet aber ein kleines Vermögen.

    Evtl.kann man eine "0 VDC-Schiene" herstellen.

    Gruß Gert
     
Thema:

Probleme mit analogen 4-20mA Ausgängen

Die Seite wird geladen...

Probleme mit analogen 4-20mA Ausgängen - Ähnliche Themen

  1. Probleme mit DSL-Anschluss im Neubau

    Probleme mit DSL-Anschluss im Neubau: Guten Morgen zusammen, am vergangenen Freitag wurde in unserem neuen Heim der DSL-Anschluss installiert. Seitdem gibt es Probleme. Im Haus gibt...
  2. Probleme mit Fluke DMS 1.6 professional

    Probleme mit Fluke DMS 1.6 professional: Guten Tag zusammen, ich habe folgendes Problem und suche dringend um hilfe! :( Folgendes: Ich kann am Programm an der Menüleiste nichts...
  3. Probleme mit Anschluss Netzwerkdose

    Probleme mit Anschluss Netzwerkdose: Ich habe 15 Meter CAT7 Verlegekabel S/FTP verlegt und an beide Enden jeweils eine CAT6 e Netzwerkdose mit dem LSA Werkzeug nach dem Standard TIA-...
  4. Probleme mit LS Schalter nach Thyristorsteller

    Probleme mit LS Schalter nach Thyristorsteller: Guten Abend, Folgender Aufbau: Leistungssteller (AEG Thyro 2 A) regelt die Leistung eines Heizregisters (2 Phasen gepulst 1Phase...
  5. Probleme mit Tasterschaltung ELTAKO

    Probleme mit Tasterschaltung ELTAKO: Hoffe hier kann mir weiter geholfen werden. Habe in der Forensuche nicht die erhoffte Antwort gefunden. Ich habe eine Tasterschaltung (drei...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden